Tuesday , 17 January 2017
Home » Bài theo kỳ » Thiết kế hệ thống mạng thực tế

Thiết kế hệ thống mạng thực tế

Thiết kế hệ thống mạng thực tế

Mô hìnhthực tế 1:

Một công ty có tòa nhà 2 tầng, mỗi tầng có khoảng 50 máy tính, công ty muốn triển khai hệ thống mạng LAN với chi phí có thể mua được các thiết bị sau:

 

1 1 switch Cisco layer3
2 5 switch Cisco layer 2
3 01 đường truyền Internet ADSL
4 02 Access Point
5 03 Server nội bộ

 

Bạn hãy thiết kế các Vlan, hoạch định IP, định tuyến cho mạng trên đảm bảo tính bảo mật, dễ dàng khắc phục sự cố khi có lỗi, miền broadcast nhỏ cho tốc độ mạng nhanh nhưng độ phức tạm ít.

Với yêu cầu trên tôi xin đưa ra đề xuất sơ đồ mạng giả lập được thiết kế trên Packet Tracert (trong mô hình sử dụng đại diện 2 switch và một số pc, laptop):

so do mang

Sơ đồ trên ta tiến hành hoạch định địa chỉ IP như sau:

Tầng 1: Các PC và Wireless nhận dải IP 172.16.1.x/24

Tầng 2: Các PC và Wireless nhận dải IP 172.16.2.x/24

2 tầng này nhận IP từ server DHCP ở khu vực Server;

Khu vực server nhận dải IP 172.16.3.x/24; khu vực này đặt IP tĩnh

Các bước thực hiện cấu hình:

–          Trên switch L2 tầng 1 mặc định đã có VLAN 1 và các port đều thuộc VLAN này nên đã xong

–          Trên switch L2 tầng 2, ta tạo VLAN 2 và đưa các port đều thuộc VLAN 2 này

–          Trên switch L2 ở phòng server tạo VLAN 3, và đưa các port vào VLAN này

Tại Switch layer 3, tạo thêm VLAN 2, VLAN 3 và đặt địa chỉ IP cho các VLAN này tương ứng với các tầng và phòng server là:

+ Vlan 1: 172.16.1.1/24

+ Vlan 2: 172.16.2.1/24

+ Vlan 3: 172.16.3.1/24

+ Vlan 4: 192.168.1.2/24

Và trên mỗi interface của VLAN ta chuyển tiếp request DHCP tới server DHCP nằm trong phòng Server bằng lệnh IP helper-address

–          Định tuyến cho các VLAN trên switch layer 3 bằng lệnh IP Routing ở chế độ global

–          Định tuyến default route tới ADSL

Chi tiết cấu hình:

+ Tại switch tầng 1:

Tại switch này ta để mặc định vì Vlan 1 đã được tạo và tất cả các port đều thuộc Vlan 1 này

+ Tại switch tầng 2:

Tạo vlan 2 và đưa tất cả các port vào vlan 2

Switch(config)#vlan 2

Switch(config)#name tang2

Switch(config)#switchport access vlan 2

+ Tại switch server:

Tạo vlan 3 và đưa tất cả các port vào vlan 3

Switch(config)#vlan 3

Switch(config)#name server

Switch(config)#switchport access vlan 3

+ Tại switch layer3:

Bước 1: Tạo các Vlan 2,3,4

Switch(config)#vlan 2

Switch(config-vlan)#

Switch(config-vlan)#name tang2

Switch(config-vlan)#vlan 3

Switch(config-vlan)#name server

Switch(config-vlan)#vlan 4

Switch(config-vlan)#name ADSL

Switch(config-vlan)#

Bước 2: đặt IP cho các VLan

Switch#conf terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#interface  vlan 1

Switch(config-if)#ip address 172.16.1.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#

Switch(config-if)#interface  vlan 2

Switch(config-if)#ip address 172.16.2.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#int erface vlan 3

Switch(config-if)#ip address 172.16.3.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#interface  vlan 4

Switch(config-if)#ip address 192.168.1.2 255.255.255.0

Switch(config-if)#no shutdown

show run

Bước 3: Kích hoạt tính năng định tuyến

Switch(config)#ip routing

Bước 4: Định tuyến Default route qua IP của ADSL

Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2

Bước 5: Đưa cổng f0/4 vào Vlan 4

Switch(config)#interface f0/4

Switch(config-if)#switchport access vlan 4

Bước 6: Trunk các cổng f0/1 –f0/3 (trong bài này ta có thể không cần trunk các cổng này mà bằng cách đưa các cổng kết nối tương ứng với các switch vào các vlan tương ứng, nhưng vì tương lai ta có thể có nhiều VLAN trên các switch layer 2 nữa nên giải pháp tổng thể ta nên Trunk các cổng này)

Switch(config-if-range)#interface range f0/1 – 3

Switch(config-if-range)#switchport trunk encapsulation dot1q

Switch(config-if-range)#switchport mode trunk

Bước 7: Chuyển tiếp request DHCP tới server DHCP nằm trong phòng cho các Vlan 1 và 2

Switch(config)#int vlan 1

Switch(config-if)#ip helper-address 172.16.3.2

Switch(config-if)#int vlan 2

Switch(config-if)#ip helper-address 172.16.3.2

Bước 8: Ghi lại cấu hình

Switch#write memory

+ Tại Router ADSL: Ta cần thêm tuyến static route vào các Vlan 1,2,3

Switch(config)#ip route 172.16.0.0 255.255.0.0 192.168.1.2

+ Tại server DHCP ta cấu hình các dải ip như hình

DHCP server

+ Còn các cấu hình IP thì các bạn cấu hình như trên sơ đồ

Kết quả của các PC và laptop ping tới máy ngoài Internet 203.162.0.2 như sau:

laptop1

Chi tiết file cấu hình bạn có thể download tại đây:

[sociallocker]http://anninhmang.net/files/switch%20layer3.pkt[/sociallocker]

Best wish for you!

Lượt xem (7312)

About Nguyễn Thanh Sơn

Nguyễn Thanh Sơn
Network Security, Web Design, Computer Science

Xem thêm

mohinh-juniper

Cấu hình mô hình mạng thực tế với thiết bị Juniper

  Tiếp tục với các bài viết cơ bản trên thiết bị Juniper, hôm nay …

Để lại bình luận:

Loading Facebook Comments ...

Leave a Reply

Your email address will not be published. Required fields are marked *