Tuesday , 17 January 2017
Home » Bài theo kỳ » Định tuyến các Vlan và cài đặt DHCP

Định tuyến các Vlan và cài đặt DHCP

 Định tuyến các Vlan bằng cách chia Sub Interface trên Router

Bạn tham khảo thêm bài Vlan trên Switch Cisco

Trên cổng vật lý của Router ta có thể chia ra nhiều cổng con logic (sub interface), để vào sub interface ta có lệnh router(config)#interface f0/0.x (x là số bất kỳ từ 1 tới gần 2 tỷ, số này bất kỳ khi bạn cấu hình Vlan) và mỗi sub sẽ đóng gói cho mỗi Vlan tương ứng bằng lệnh encapsulation dot1Q Vlan_ID. Và tại mỗi sub ta đặt địa chỉ IP tương ứng cho các Vlan bạn định đại diện.

Để rõ hơn chúng ta cùng cấu hình ví dụ sau:

Ta dùng phần mềm mô phỏng Packet Tracer và thiết kế 1 mạng như sơ đồ sau: ( hình 1 )

mh

 

Tiến hành cấu hình.

+) Tại Router0:

Router>enable

Router#conf t

Router(config)#int f0/0

Router(config-if)#no shut down

Router(config-if)#exit
Router(config)#int f0/0.1
Router(config-subif)#encap dot1Q 1
Router(config-subif)#ip address 172.16.1.1 255.255.255.0

Router(config-subif)#exit
Router(config)#int f0/0.2
Router(config-subif)#encap dot1Q 2
Router(config-subif)#ip address 172.16.2.1 255.255.255.0

Router(config-subif)#exit
Router(config)#int f0/0.3
Router(config-subif)#encap dot1Q 3
Router(config-subif)#ip address 172.16.3.1 255.255.255.0

( Địac chỉ IP  là các Default Gateway của các vlan 1, 2, 3 )

+ ) Tại Switch 1 ( Ta tạo ra vlan 1 và add 2 cổng f0/3 – f0/4 vào và trunk 2 cổng  f0/1 -f0/2 )

Switch>en

Switch#conf t

Switch(config)#vlan 1

Switch(config-vlan)#int range f0/2 – f0/3

Switch(config-if-range)#switchport access vlan 1

Switch(config-if-range)#exit

Switch(config)#int range f0/1 – f0/2

Switch(config-if-range)#switchport mode trunk

 

+ ) Tại Switch2

Switch>en

Switch#conf t

Switch(config)#int range f0/1 – f0/2

Switch(config-if-range)#switchport mode trunk

Switch(config-if-range)#exit

Switch(config)#vlan 2

Switch(config-vlan)#int range f0/3 – f0/4

Switch(config-if-range)#switchport access vlan 2

 

+) Tại Switch3 (  Ta tạo ra vlan 3 và add 2 cổng f0/2 – f0/3 vào và trunk 1 cổng  f0/1 ).

Switch>en

Switch#conf t

Switch(config)#vlan 3

Switch(config-vlan)#int range f0/2 – f0/3

Switch(config-if-range)#switchport access vlan 3

Switch(config-if-range)#exit

Switch(config)#int range f0/1

Switch(config-if-range)#switchport mode trunk

 

+)  Tại các PC5 , PC3 , PC1 ( ta đặt ip theo thứ tự thuộc network vlan 1, vlan 2, vlan 3 ) như hình 1

Bây giờ các bạn ping thử các máy đã thông với nhau chưa?

ví dụ ta ping từ PC5 tới PC1 và PC3 ( hình 2 )

ping

 

Tiếp theo ta cấp DHCP cho các PC0 , PC2 , PC4

+) Tại server0

Ta cấu hình cho cả 3 vlan và đặt tên cho nó ( như hình 3 )

sevr2

Tiếp theo ta cấu hình trên Router0 như sau:

Router#conf t

Router(config)#int f0/0.1

Router(config-if)#ip helper-address 172.16.1.10 ( ip cua server )

Router(config-if)#exit

Router(config)#int f0/0.2
Router(config-if)#ip helper-address 172.16.1.10 ( ip cua server )

Router(config-if)#exit

Router(config)#int f0/0.3
Router(config-if)#ip helper-address 172.16.1.10 ( ip cua server )

Cuối cùng bạn vào máy PC0, PC2, PC4 để chế độ DHCP thì pc sẽ nhận được IP cùng với network vlan đó ( hình 4 )

dhcp

 

Chúc các bạn thành công

 

 

Lượt xem (7150)

About Hit Le

Hit Le

Xem thêm

mohinh-juniper

Cấu hình mô hình mạng thực tế với thiết bị Juniper

  Tiếp tục với các bài viết cơ bản trên thiết bị Juniper, hôm nay …

Để lại bình luận:

Loading Facebook Comments ...

Leave a Reply

Your email address will not be published. Required fields are marked *