Saturday , 23 March 2019
Home » Bài theo kỳ » Cấu hình định tuyến tĩnh ( Configuring Static Routing )

Cấu hình định tuyến tĩnh ( Configuring Static Routing )

Bài 1: Cấu hình định tuyến tĩnh

Bài 2: Cấu hình Định tuyến mặc định (default Route)

I . Khái niệm

– Định tuyến  là quá trình mà router thực hiện để chuyển gói dữ liệu tới mạng đích.  Router dựa vào địa chỉ IP đích của gói tin để chuyển gói ra các Interface theo đúng hướng đến đích cuối cùng. (Mời các bạn xem lại bài viết: Định truyến trên Router)

– Đối với định tuyến tĩnh, các thông tin về đường đi là do người quản trị mạng chỉ định cho Router. Khi đó người quản trị có chức năng cập nhật, xóa bỏ các thông tin về đường đi cho router.

II. Đặc điểm:

–                      Áp dụng cho môi trường mạng nhỏ (khoảng dưới 5 router)

–                      Không tiêu tốn băng thông đường truyền để các thông báo giữa các Router về các đường đi

–                      Không tiêu tốn tài nguyên của hệ thống Router tính toán đường đi như định tuyến động

–                      Bảo mật vì Router chỉ hoạt động dựa vào các đường đi mà Admin chỉ định

–                      Rất khó khắc phục sự cố, phải cấu hình lại khi có sự thay đổi về địa chỉ mạng cũng như các thiết bị

III. Cấu hình

– Đầu tiên ta vào cấu hình IP cho 2 router

Tại Router0

Router>en

Router#conf t

Router(config)#hostname Router0

Router0(config)#interface f0/0

Router0(config-if)#ip address 10.0.0.1 255.255.255.0

Router0(config-if)#no shutdown

Router0(config-if)#exit

Router0(config)#interface f0/1

Router0(config-if)#ip address 192.168.1.1 255.255.255.0

Router0(config-if)#no shutdown

Tại Router1

Router>en

Router#conf t

Router(config)#hostname Router1

Router0(config)#interface f0/0

Router0(config-if)#ip address 10.0.0.2 255.255.255.0

Router0(config-if)#no shutdown

Router0(config-if)#exit

Router0(config)#interface f0/1

Router0(config-if)#ip address 172.16.1.1 255.255.255.0

Router0(config-if)#no shutdown

 

– Để kích hoạt định tuyến tĩnh chúng ta có 2 cách cấu hình sau:

Cách 1:

Router(config)#ip route <Network_đích> <Subnet Mask của Network_đích> <IP nexthop>

Hoặc cách 2:

Router(config)#ip route <Network_đích> <Subnet Mask của Network_đích> <exit Interface>

Ví dụ ta với mô hình sau: Hình 1: Mô hình mạng sử dụng cấu hình Static

Hình 1: Mô hình mạng sử dụng cấu hình Static

Cách 1: Router(config)#ip route <Network_đích> <Subnet Mask của Network_đích> <IP nexthop>

+ Network: địa chỉ Network của các IP trong mạng (ví dụ trên network =172.16.1.0

+ Nexthop: Là ip của cổng của Router kế tiếp trên đường đi tới network đích của packet

Tại Router0 , Network đích là 172.16.1.0 Subnet Mask 255.255.255.0; để sang được network này Router0 phải đi qua cổng F0/0 của Router1, mà cổng IP này có địa chỉ IP=10.0.0.1. Vậy cách 1 chúng ta có lệnh

Router0>en

Router0#conf t

Router0(config)#ip route  172.16.1.0 255.255.255.0 10.0.0.1

Tương tự như vậy trên Router1 muốn gửi packet tới network đích là 192.168.1.0 subnet mask 255.255.255.0 thì phải đi qua cổng nexthop là f0/0 của Router0 (mà IP của cổng này là 10.0.0.2)

Vậy trên Router1 ta có cấu hình:

Router1>en

Router1#conf t

Router1(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.2

Note: Ta phải cấu hình trên tất cả các Router thì mới Ping thấy nhau vì gói tin phải được định tuyến đi và về (gửi và nhận)

Tại các PC ta đặt IP cho các máy theo thứ tự như hình 1

Cách 2: Router(config)#ip route <Network_đích> <Subnet Mask của Network_đích> <exit Interface>

+ Exit Interface: Tên cổng thoát ra của Packet tại router được cấu hình ví dụ f0/0, s0/0

Trên Router0 muốn sang network đích thì gói tin sẽ được thoát ra từ cổng F0/0 chứ không phải f0/1 của Router này, nên ta có lệnh:

Router0(config)#ip route  172.16.1.0 255.255.255.0 f0/0

Tương tự ta có lệnh trên Router1:

Router0(config)#ip route  172.16.1.0 255.255.255.0 f0/0

Kết quả:

Với các PC và các cổng của Router đặt như trên hình ta có thể Ping từ PC0 tới tất cả các PC khác trong LAN

Chú ý: Với cách 2 trên ta không thể cấu hình trên môi trường mạng Multi Access như sau:

 Mô hình mạng trong môi trường đa truy nhập (Multi Access)

Hình 2: Mô hình mạng trong môi trường đa truy nhập (Multi Access)

Vì nếu Router0 muốn sang network đích là 172.16.1.0 mà cứ thoát ra khỏi cổng f0/0 trên Router0 thì packet đó ra tới Switch không thể biết là qua Router1 hay Router2 đây.

 

Lượt xem (7818)

About Hit Le

Hit Le

Xem thêm

Năm 2017: Người dùng Việt Nam thiệt hại 12.300 tỉ đồng vì virus máy tính

(NLĐO) – Năm 2017, thiệt hại do virus máy tính gây ra đối với người …

Để lại bình luận:

Loading Facebook Comments ...

Leave a Reply

Your email address will not be published. Required fields are marked *