Monday , 20 August 2018
Home » Tin An ninh mạng » Bảo Mật Mạng » 50.000 trang web bị hack qua lỗ hổng trong plugin MailPoet trên WordPress

50.000 trang web bị hack qua lỗ hổng trong plugin MailPoet trên WordPress

MailPoet, trước đây gọi là Wysija Newsletter, là một WordPress Plugin với hơn 1,7 triệu lượt tải về cho phép các nhà phát triển chạy WordPress sử dụng để gửi và quản lý các thông báo, cập nhật tin đến cho người dùng trong hệ thống.

Một lỗ hổng nghiêm trọng được phát hiện trong plugin MailPoet của WordPress có thể cho phép kẻ tấn công tiêm nhiễm bất kỳ tập tin độc hại nào lên máy chủ của website. Hacker có thể thay đổi giao diện website (defacement) hoặc chiếm quyền điều khiển website để phát tán mã độc.

Công ty bảo mật Sucuri đã chỉ ra các lỗ hổng nghiêm trọng và nói rằng trong vòng ba tuần kể từ khi lỗ hổng được công bố, hơn 50.000 trang web đã bị khai thác và cài đặt backdoor lên hệ thống thông qua lỗ hổng này. Một số website bị tấn công dù không sử dụng mailPoet hay chạy trên wordpress. Kẻ tấn công đã sử dụng kỹ thuật tấn công “local attack” để tấn công vào một website khác cùng nằm trên máy chủ với website có có lỗ hổng.

Các website thường bị các kẻ tấn công ghi đè lên các tập tin trên hệ thống và nếu không có cơ chế sao lưu tốt thì rất khó phụ hồi lại hệ thống. Một số website thường xuất hiện thông báo lỗi khi cập nhật lại hệ thống:

Parse error: syntax error, unexpected ‘)’ in /home/user/public_html/site/wp-config.php on line 91.

Công ty này đang thử nghiệm với tất cả các phiên bản của MailPoet và cho thấy mọi phiên bản đều có thể bị tấn công, ngoại trừ phiên bản gần đây nhất 2.6.7 mới phát hành. Vì vậy để đảm bảo an ninh các quản trị của website nên cập nhật phiên bản mới này càng sớm càng tốt. Hãng bảo mật Sucuri rất nỗ lực trong việc tìm kiếm các lỗ hổng trong WordPress  và khuyến khích người dùng cài đặt các bản cập nhật. Một tuần trước, công ty đã thúc giục người dùng nâng cấp phiên bản WordPress do một lỗ hổng đLỗ hổng báo mật trên MailPoetược tìm thấy trong các plugin WordPress WPtouch có khả năng cho phép bất kỳ người dùng nào đăng nhập trái phép và upload các tập tin PHP độc hại hoặc backdoors lên máy chủ mục tiêu mà không cần các đặc quyền quản trị nào.

Sucuri cũng tìm thấy hai lỗ hổng nghiêm trọng trong các plugin WordPress SEO phổ biến được gọi là All in One SEO pack và một lỗ hổng cho phép thực thì mã độc từ xa (RCE) trong Disqus Comment Plugin của WordPress vài tuần trước.

Theo Thehackernews.com

Lượt xem (667)

About Nguyễn Thanh Sơn

Nguyễn Thanh Sơn
Network Security, Web Design, Computer Science

Xem thêm

Sau khi bị tấn công rò rỉ dữ liệu, Uber trả cho hacker 100,000 USD để giữ bí mật

UBer thông báo đã xả ra một vụ rò rỉ dữ liệu khổng lồ vào …

Để lại bình luận:

Loading Facebook Comments ...

Leave a Reply

Your email address will not be published. Required fields are marked *